Depends: xxx but it is not going to be installed解决方法

今天安装个firewalld防火墙的时候一直安装不上,提示:

The following packages have unmet dependencies:
 firewalld : Depends: python3-slip-dbus but it is not going to be installed
             Recommends: ebtables (>= 2.0.10.4-3.1~) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
Depends: xxx but it is not going to be installed解决方法

然后网上查了说先安装aptitude,然后用aptitude来安装软件包,结果安装aptitude的时候又报错:

The following packages have unmet dependencies:
 aptitude : Depends: libapt-pkg5.0 (>= 1.1) but it is not going to be installed
            Recommends: libparse-debianchangelog-perl but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
Depends: xxx but it is not going to be installed解决方法

最后抱着试一下的心态换个源再安装,没想到换源后真的安装成功了。

Depends: xxx but it is not going to be installed解决方法

最后分享一下更换的源(Ubuntu20.04,腾讯的源)

deb https://mirrors.cloud.tencent.com/ubuntu/ jammy main restricted universe multiverse
deb-src https://mirrors.cloud.tencent.com/ubuntu/ jammy main restricted universe multiverse
deb https://mirrors.cloud.tencent.com/ubuntu/ jammy-security main restricted universe multiverse
deb-src https://mirrors.cloud.tencent.com/ubuntu/ jammy-security main restricted universe multiverse
deb https://mirrors.cloud.tencent.com/ubuntu/ jammy-updates main restricted universe multiverse
deb-src https://mirrors.cloud.tencent.com/ubuntu/ jammy-updates main restricted universe multiverse
deb https://mirrors.cloud.tencent.com/ubuntu/ jammy-proposed main restricted universe multiverse
deb-src https://mirrors.cloud.tencent.com/ubuntu/ jammy-proposed main restricted universe multiverse
deb https://mirrors.cloud.tencent.com/ubuntu/ jammy-backports main restricted universe multiverse
deb-src https://mirrors.cloud.tencent.com/ubuntu/ jammy-backports main restricted universe multiverse

原创文章,作者:小哆啦,如若转载,请注明出处:https://www.notevm.com/a/6217.html

(0)
上一篇 2022年6月23日 09:00
下一篇 2022年6月25日 10:13

相关推荐